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5. Working with Data - Filtering Data  

5.1. Introduction 

If your worksheet contains a lot of content, it can be difficult to find information quickly. 

Filters can be used to narrow down the data in your worksheet, allowing you to view only 

the information you need. 

5.2. To filter data: 

In our example, we'll apply a filter to an equipment log worksheet to display only the laptops 

and projectors that are available for checkout. 

1. In order for filtering to work correctly, your worksheet should include a header row, 

which is used to identify the name of each column. In our example, our worksheet is 

organized into different columns identified by the header cells in row 1: ID#, Type, 

Equipment Detail, and so on. 

 

2. Select the Data tab, then click the Filter command. 

 

3. A drop-down arrow will appear in the header cell for each column. 

4. Click the drop-down arrow for the column you want to filter. In our example, we 

will filter column B to view only certain types of equipment. 
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5. The Filter menu will appear. 

6. Uncheck the box next to Select All to quickly deselect all data. 

 

7. Check the boxes next to the data you want to filter, then click OK. In this example, 

we will check Laptop and Projector to view only these types of equipment. 
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8. The data will be filtered, temporarily hiding any content that doesn't match the 

criteria. In our example, only laptops and projectors are visible. 
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Filtering options can also be accessed from the Sort & Filter command on the Home tab. 

 

5.3. To apply multiple filters: 

Filters are cumulative, which means you can apply multiple filters to help narrow down 

your results. In this example, we've already filtered our worksheet to show laptops and 

projectors, and we'd like to narrow it down further to only show laptops and projectors that 

were checked out in August. 

1. Click the drop-down arrow for the column you want to filter. In this example, we 

will add a filter to column D to view information by date. 
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2. The Filter menu will appear. 

3. Check or uncheck the boxes depending on the data you want to filter, then click OK. 

In our example, we'll uncheck everything except for August. 
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4. The new filter will be applied. In our example, the worksheet is now filtered to show 

only laptops and projectors that were checked out in August. 
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5.4. To clear a filter: 

After applying a filter, you may want to remove—or clear—it from your worksheet so you'll 

be able to filter content in different ways. 

1. Click the drop-down arrow for the filter you want to clear. In our example, we'll 

clear the filter in column D. 

 

2. The Filter menu will appear. 

3. Choose Clear Filter From [COLUMN NAME] from the Filter menu. In our 

example, we'll select Clear Filter From "Checked Out". 

 

4. The filter will be cleared from the column. The previously hidden data will be 

displayed. 
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To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

5.5. Advanced filtering 

If you need a filter for something specific, basic filtering may not give you enough options. 

Fortunately, Excel includes many advanced filtering tools, including search, text, date, and 

number filtering, which can narrow your results to help find exactly what you need. 

5.5.1. To filter with search: 

Excel allows you to search for data that contains an exact phrase, number, date, and more. In 

our example, we'll use this feature to show only Saris brand products in our equipment log. 

1. Select the Data tab, then click the Filter command. A drop-down arrow will appear 

in the header cell for each column. Note: If you've already added filters to your 

worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll 

filter column C. 
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3. The Filter menu will appear. Enter a search term into the search box. Search results 

will appear automatically below the Text Filters field as you type. In our example, 

we'll type saris to find all Saris brand equipment. When you're done, click OK. 

 

4. The worksheet will be filtered according to your search term. In our example, the 

worksheet is now filtered to show only Saris brand equipment. 
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5.5.2. To use advanced text filters: 

Advanced text filters can be used to display more specific information, like cells that 

contain a certain number of characters or data that excludes a specific word or number. In our 

example, we'd like to exclude any item containing the word laptop. 

1. Select the Data tab, then click the Filter command. A drop-down arrow will appear 

in the header cell for each column. Note: If you've already added filters to your 

worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll 

filter column C. 

 

3. The Filter menu will appear. Hover the mouse over Text Filters, then select the 

desired text filter from the drop-down menu. In our example, we'll choose Does Not 

Contain to view data that does not contain specific text. 
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4. The Custom AutoFilter dialog box will appear. Enter the desired text to the right of 

the filter, then click OK. In our example, we'll type laptop to exclude any items 

containing this word. 
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5. The data will be filtered by the selected text filter. In our example, our worksheet now 

displays items that do not contain the word laptop. 

 

5.5.3. To use advanced number filters: 

Advanced number filters allow you to manipulate numbered data in different ways. In this 

example, we'll display only certain types of equipment based on the range of ID numbers. 

1. Select the Data tab on the Ribbon, then click the Filter command. A drop-down 

arrow will appear in the header cell for each column. Note: If you've already added 

filters to your worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll 

filter column A to view only a certain range of ID numbers. 

 

3. The Filter menu will appear. Hover the mouse over Number Filters, then select the 

desired number filter from the drop-down menu. In our example, we'll choose 

Between to view ID numbers between a specific number range. 



 15   

 

4. The Custom AutoFilter dialog box will appear. Enter the desired number(s) to the 

right of each filter, then click OK. In our example, we want to filter for ID numbers 

greater than or equal to 3000 but less than or equal to 6000, which will display ID 

numbers in the 3000-6000 range. 
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5. The data will be filtered by the selected number filter. In our example, only items with 

an ID number between 3000 and 6000 are visible. 

 

5.5.4. To use advanced date filters: 

Advanced date filters can be used to view information from a certain time period, such as 

last year, next quarter, or between two dates. In this example, we'll use advanced date filters 

to view only equipment that has been checked out between July 15 and August 15. 

1. Select the Data tab, then click the Filter command. A drop-down arrow will appear 

in the header cell for each column. Note: If you've already added filters to your 

worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll 

filter column D to view only a certain range of dates. 

 

3. The Filter menu will appear. Hover the mouse over Date Filters, then select the 

desired date filter from the drop-down menu. In our example, we'll select Between to 

view equipment that has been checked out between July 15 and August 15. 
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4. The Custom AutoFilter dialog box will appear. Enter the desired date(s) to the right 

of each filter, then click OK. In our example, we want to filter for dates after or equal 

to July 15, 2015, and before or equal to August 15, 2015, which will display a range 

between these dates. 
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5. The worksheet will be filtered by the selected date filter. In our example, we can now 

see which items have been checked out between July 15 and August 15. 
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6. Working with Data - Tables 

6.1. Introduction 

Once you've entered information into your worksheet, you may want to format your data as a 

table. Just like regular formatting, tables can improve the look and feel of your workbook, 

and they'll also help you organize your content and make your data easier to use. Excel 

includes several tools and predefined table styles, allowing you to create tables quickly and 

easily. 

6.2. To format data as a table: 

1. Select the cells you want to format as a table. In our example, we'll select the cell 

range A2:D9. 

 

2. From the Home tab, click the Format as Table command in the Styles group. 

 

3. Select a table style from the drop-down menu. 
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4. A dialog box will appear, confirming the selected cell range for the table. 

5. If your table has headers, check the box next to My table has headers, then click 

OK. 

 

6. The cell range will be formatted in the selected table style. 
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Tables include filtering by default. You can filter your data at any time using the drop-down 

arrows in the header cells. To learn more, review our lesson on Filtering Data. 

6.3. Modifying tables 

It's easy to modify the look and feel of any table after adding it to a worksheet. Excel includes 

many different options for customizing a table, including adding rows or columns and 

changing the table style. 

6.3.1. To add rows or columns to a table: 

If you need to fit more content into your table, Excel allows you to modify the table size by 

including additional rows and columns. There are two simple ways to change the table size: 

• Enter new content into any adjacent row or column. The row or column will be roped 

into the table automatically. 

http://www.gcflearnfree.org/excel2016/filtering-data/1/
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• Click and drag the bottom-right corner of the table to create additional rows or 

columns. 
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6.3.2. To change the table style: 

1. Select any cell in your table, then click the Design tab. 

 

2. Locate the Table Styles group, then click the More drop-down arrow to see all 

available table styles. 

 

3. Select the desired table style. 
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4. The table style will be applied. 
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6.3.3. To modify table style options: 

You can turn various options on or off to change the appearance of any table. There are 

several options: Header Row, Total Row, Banded Rows, First Column, Last Column, 

Banded Columns, and Filter Button.Select any cell in your table, then click the Design tab. 

1. Check or uncheck the desired options in the Table Style Options group. In our 

example, we'll check Total Row to automatically include a total for our table. 

 

2. The table style will be modified. In our example, a new row has been added to the 

table with a formula that automatically calculates the total value of the cells in 

column D. 

 

Depending on the type of content you have—and the table style you've chosen—these 

options can affect your table's appearance in various ways. You may need to experiment with 

a few different options to find the exact style you want. 
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6.3.4. To remove a table: 

It's possible to remove a table from your workbook without losing any of your data. 

However, this can cause issues with certain types of formatting, including colors, fonts, and 

banded rows. Before you use this option, make sure you're prepared to reformat your cells if 

necessary. 

1. Select any cell in your table, then click the Design tab. 

2. Click the Convert to Range command in the Tools group. 

 

3. A dialog box will appear. Click Yes. 

 

4. The range will no longer be a table, but the cells will retain their data and formatting. 
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To restart your formatting from scratch, click the Clear command on the Home tab. Next, 

choose Clear Formats from the menu. 
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7. Working with Data - Charts 

7.1. Introduction 

It can be difficult to interpret Excel workbooks that contain a lot of data. Charts allow you to 

illustrate your workbook data graphically, which makes it easy to visualize comparisons 

and trends. 

7.2. Understanding charts 

Excel has several different types of charts, allowing you to choose the one that best fits your 

data. In order to use charts effectively, you'll need to understand how different charts are 

used. 

Click the arrows in the slideshow below to learn more about the types of charts in Excel. 

 

Excel has a variety of chart types, each with its own advantages. Click the arrows to see some 

of the different types of charts available in Excel. 
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•  

 

Column charts use vertical bars to represent data. They can work with many different types of 

data, but they're most frequently used for comparing information. 

•  

 

Line charts are ideal for showing trends. The data points are connected with lines, making it 

easy to see whether values are increasing or decreasing over time. 
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•  

 

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so 

it's easy to see which values make up the percentage of a whole. 

•  

 

Bar charts work just like column charts, but they use horizontal rather than vertical bars. 
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•  

 

Area charts are similar to line charts, except the areas under the lines are filled in. 

•  

 

Surface charts allow you to display data across a 3D landscape. They work best with large 

data sets, allowing you to see a variety of information at the same time. 
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In addition to chart types, you'll need to understand how to read a chart. Charts contain 

several different elements, or parts, that can help you interpret the data. 

Click the buttons in the interactive below to learn about the different parts of a chart.  

 

7.3. To insert a chart: 

1. Select the cells you want to chart, including the column titles and row labels. These 

cells will be the source data for the chart. In our example, we'll select cells A1:F6. 

 

2. From the Insert tab, click the desired Chart command. In our example, we'll select 

Column. 
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3. Choose the desired chart type from the drop-down menu. 

 

4. The Selected chart will be inserted into the worksheet. 

 

If you're not sure which type of chart to use, the Recommended Charts command will 

suggest several different charts based on the source data. 
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7.4. Chart and layout style 

After inserting a chart, there are several things you may want to change about the way your 

data is displayed. It's easy to edit a chart's layout and style from the Design tab. 

• Excel allows you to add chart elements—such as chart titles, legends, and data 

labels—to make your chart easier to read. To add a chart element, click the Add 

Chart Element command on the Design tab, then choose the desired element from 

the drop-down menu. 

 

• To edit a chart element, like a chart title, simply double-click the placeholder and 

begin typing. 
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• If you don't want to add chart elements individually, you can use one of Excel's 

predefined layouts. Simply click the Quick Layout command, then choose the 

desired layout from the drop-down menu. 

 

• Excel also includes several chart styles, which allow you to quickly modify the look 

and feel of your chart. To change the chart style, select the desired style from the 
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Chart styles group. You can also click the drop-down arrow on the right to see more 

styles. 

 

You can also use the chart formatting shortcut buttons to quickly add chart elements, 

change the chart style, and filter the chart data. 

 

7.5. Other chart options 

There are many other ways to customize and organize your charts. For example, Excel allows 

you to rearrange a chart's data, change the chart type, and even move the chart to a 

different location in a workbook. 

7.5.1. To switch row and column data: 

Sometimes you may want to change the way charts group your data. For example, in the 

chart below Book Sales data is grouped by genre, with columns for each month. However, 

we could switch the rows and columns so the chart will group the data by month, with 

columns for each genre. In both cases, the chart contains the same data—it's just organized 

differently. 
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1. Select the chart you want to modify.  

2. From the Design tab, select the Switch Row/Column command. 

 

3. The rows and columns will be switched. In our example, the data is now grouped by 

month, with columns for each genre. 
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7.5.2. To change the chart type: 

If you find that your data isn't well suited to a certain chart, it's easy to switch to a new chart 

type. In our example, we'll change our chart from a column chart to a line chart. 

1. From the Design tab, click the Change Chart Type command. 

 

2. The Change Chart Type dialog box will appear. Select a new chart type and layout, 

then click OK. In our example, we'll choose a Line chart. 
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3. The selected chart type will appear. In our example, the line chart makes it easier to 

see trends in sales data over time. 
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7.5.3. To move a chart: 

Whenever you insert a new chart, it will appear as an object on the same worksheet that 

contains its source data. Alternatively, you can move the chart to a new worksheet to help 

keep your data organized. 

1. Select the chart you want to move.  

2. Click the Design tab, then select the Move Chart command. 

 

3. The Move Chart dialog box will appear. Select the desired location for the chart. In 

our example, we'll choose to move it to a New sheet, which will create a new 

worksheet.  

4. Click OK. 
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5. The chart will appear in the selected location. In our example, the chart now appears 

on a new worksheet. 

 

7.5.3.1. Keeping charts up to date 

By default, when you add more data to your spreadsheet, the chart may not include the new 

data. To fix this, you can adjust the data range. Simply click the chart, and it will highlight 

the data range in your spreadsheet. You can then click and drag the handle in the lower-right 

corner to change the data range.  
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If you frequently add more data to your spreadsheet, it may become tedious to update the data 

range. Luckily, there is an easier way. Simply format your source data as a table, then create 

a chart based on that table. When you add more data below the table, it will automatically 

be included in both the table and the chart, keeping everything consistent and up to date. 

 

 


