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10. Working with Data - Tables

10.1. Introduction

Once you've entered information into your worksheet, you may want to format your data as a
table. Just like regular formatting, tables can improve the look and feel of your workbook,
and they'll also help you organize your content and make your data easier to use. Excel
includes several tools and predefined table styles, allowing you to create tables quickly and
easily.

10.2. To format data as a table:

1. Select the cells you want to format as a table. In our example, we'll select the cell
range A2:D9.

A B C D
8&'@@8& Catering Invoice
Sabrosa Empanadas & More
: 1202 Biscayne Bay Drive Invoice #: 56868

Orlando, FL 32804 Date: 05/10/16
1
z IMENU ITEM UNIT PRICE QUANTITY LINE TOTAL
s |Empanadas: Beef Picadillo $2.99 15 544.85
1 |[Empanadas: Chipotle Shrimp $3.99 10 $39.90
5 |Tamales: Chicken Tinga $2.29 20 S45.80
& |Tamales: Vegetable $2.29 30 S$68.70
7 |Arepas: Carnitas S2.89 10 528.90
5 |Arepas: Queso Blanco $2.49 20 549.80
s |Beverages: Horchata $1.89 25 o 547.25
10

2. From the Home tab, click the Format as Table command in the Styles group.

Q@ Tell me what you want to do... Sign in (o_'_ Share
s - %ﬂ Insert - z - A p
# Wrap Text G | - -
i# Wrap enera - EJ ‘)} B petere -~ | 31~ ZY
3 Merge & Center - $ - 0p s g0 Conditional Formatas Cell et Sort & Find &
' " Formatting ~ Tablel/\\y Styles~ | B Format~ & = Fpar- Select-
1t P Mumber P Styles Cells Editing s

3. Select a table style from the drop-down menu.
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4. A dialog box will appear, confirming the selected cell range for the table.
5. If your table has headers, check the box next to My table has headers, then click
OK.
A B c D
SAR@S& Catering Invoice
Sabrosa Empanadas & More _
: 1202 Biscayne Bay Drive Invoice #: 5686B
Orlando, FL 32804 Date: 05/10/16
1
2 [MENU ITEM UNIT PRICE QUANTITY LINE TOTAL
s JEmpanadas: Beef Picadillo | Format As Table | ? x |15 544,85
4 EmpanadaS: ChlpOtle Shrlmp | Where is the data for your table? _10 S3990
s )Tamales: Chicken Tinga | =sasaisDss m%| 120 545.80
s ITamales: Vegetable | EAMytable has headers 130 S$68.70
7 JArepas: Carnitas | e | 110 $28.90
& JArepas: Queso Blanco ,,L.-u 20 549.80
¢ |Beverages: Horchata $1.89 25 547.25
10

6. The cell range will be formatted in the selected table style.
4



SAB}R@S[E‘. Catering Invoice

Sabrosa Empanadas & More
1202 Biscayne Bay Drive
Orlando, FL 32804

2 - -

Invoice #;: 5686B
Date: 05/10/16

-

3 |[Empanadas: Beef Picadillo 5$2.99 15 544.85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
5 Tamales: Chicken Tinga $2.29 20 545.80
6 Tamales: Vegetable $2.29 30 5$68.70
7 |Arepas: Carnitas $2.89 10 528.90
s |Arepas: Queso Blanco $2.49 20 549.80
s Beverages: Horchata $1.89 25 $47.25,

10

Tables include filtering by default. You can filter your data at any time using the drop-down
arrows in the header cells. To learn more, review our lesson on Filtering Data.

10.3. Modifying tables

It's easy to modify the look and feel of any table after adding it to a worksheet. Excel includes
many different options for customizing a table, including adding rows or columns and
changing the table style.

10.3.1. To add rows or columns to a table:

If you need to fit more content into your table, Excel allows you to modify the table size by
including additional rows and columns. There are two simple ways to change the table size:

o Enter new content into any adjacent row or column. The row or column will be roped
into the table automatically.


http://www.gcflearnfree.org/excel2016/filtering-data/1/

S A B R DSA Catering Invoice
Sabrosa Empanadas & More _
1202 Biscayne Bay Drive Invoice #: 56868

——— ) ——
Empanadas & More
Orlando, FL 32804 Date: 05/10/16

2 |
3 [Empanadas: Beef Picadillo $2.99 544.85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
s |Tamales: Chicken Tinga 52.29 20 S45.80
6 |Tamales: Vegetable $2.29 30 S$68.70
7 |Arepas: Carnitas 52.89 10 528.90
s |Arepas: Queso Blanco 52.49 20 S$49.80
9 |Beverages: Horchata S1.89 25 $47.25,

Beverages: Lemonade

—
=

e Click and drag the bottom-right corner of the table to create additional rows or
columns.

4 A | B c D

S A B R DSA Catering Invoice
Sabrosa Empanadas & More _
1202 Biscayne Bay Drive Invoice #: 56868

——— ) ——
Empanadas & More
Orlando, FL 32804 Date: 05/10/16

2 | MENU ITEM B UNIT PRICE gEQUANTITY pLINE TOTAL

3 [Empanadas: Beef Picadillo 52.99 15 544.85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
s |Tamales: Chicken Tinga 5§2.29 20 S45.80
6 [Tamales: Vegetable 52.29 30 5$68.70
7 |Arepas: Carnitas 52.89 10 528.90
s |Arepas: Queso Blanco 52.49 20 S49 .80
9 |Beverages: Horchata 51.89 25 $47.25]
10
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10.3.2. To change the table style:

1. Select any cell in your table, then click the Design tab.

E a5 - = Table Tools

File Home Insert Page Layout Formulas Data Review View

Table Mame: [3] Summarize with PivotTable % [‘1 [i=] Properties [v| Header Row [ First Column
4

Table3 BB Remove Duplicates P E Open in Browser [ ] Total Row [ Last Column
‘@' Resize Table % Convert to Range E:':is:.er EO :S €2 Unlink Banded Rows || Banded Colur
Properties Tools External Table Data Table Style Optio
A3 - e Empanadas: Beef Picadillo
A A | B C D |
S ABR [] SA Catering Invoice
Sabrosa Empanadas & More
UV : ; Invaice #: 5686R
1202 Biscayne Bay Drive
Empanadas & More
Orlando, FL 32804 Date: 05/10/16
1
g3 MENU ITEM EUNIT PRICE g QUANTITY pgELINETOTAL B
3 [Empanadas: Beef Picadillo | $2.99 15 S44.85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
5 |Tamales: Chicken Tinga $2.29 20 545.80
s | Tamales: Vegetable $2.29 30 S68.70
2. Locate the Table Styles group, then click the More drop-down arrow to see all
available table styles.
rties Header Row [ First Column Filter Button || EEEm EEEEE e | -
————— EEEEE |—==2=) EEEEE
in Browser || TotalRow [ Last Column ==y T ) SRR R
Banded Rows [ | Banded Columns ~ |=——— """ T 2SS T T @
ta Table Style Options Table Styles .

More
Quickly change the visual style of
C D E = G your table. |

3. Select the desired table style.



rties [v| HeaderRow [ | FistC “-”--- ZZ-ZZ —---- “-°-T TT-TT TTTITT “--°-
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: [v/] BandedRows [ |Bande - - -~ F=——o 2| F==== E==—=| F===2| =====
- [ e e g
C D EEEE
3 Medium
Viore — e =====
. Invoice #: 56868 [E====] ===== ==-== ===== F===7 —=--- =====
Date: 05/10/16 BEEES —S-°C 92252 55252 98982 —oo0C 22252
HEEEE =SS EEEEE EEEES BEEEEE mEEET SEEEE
T LINE TOTAL B e e
15 SA4 85 EEEES ZCZCC CCIDCC ZoCCIDC Do CZooIoZoIot
10 539_9[: -2 EEEEE EEEEE EEEEE 22 EEEER
=1 5 e e 0 i 0 0 e 0 0 0 0 1 0 el el e S Y S S S S
20 54580 EEEES E==EE EEEEE EEEEE SIS S=s=s EEEEE
30 $68.7¢ Dark
- -—-——-—-§9—-——-——-——-—-§g———"—-—-§g————-pgy——"-—"-—"-g————-ygy——— — -
r EEEEETE
B
20 549'8C=EEE
O] AEEEE—— e —— o ——
25 S-'l?.L_ ____________ -

Table Style Dark 11
il Mew Table Style...

4. The table style will be applied.

y |

A

m
]
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SHBAOSH

Empanadas & More

Catering Invoice

Sabrosa Empanadas & More
1202 Biscayne Bay Drive

Invoice #: S636BE
Orlando, FL 32804 Date: 05/10/16

$44.85

$39.90
$45.80
$68.70
$28.90
$49.80
$47.25,

g MENU ITEM B UNIT PRICE g QUANTITY pELINETOTAL =2
3 [Empanadas: Beef Picadillo | $2.99 15

4 |Empanadas: Chipotle Shrimp - $3.99 10

5 |Tamales: Chicken Tinga $2.29 20

6 | Tamales: Vegetable $2.29 30

7 |Arepas: Carnitas $2.89 10

8 |Arepas: Queso Blanco $2.49 20

9 |Beverages: Horchata $1.89 25

10




10.3.3. To modify table style options:

You can turn various options on or off to change the appearance of any table. There are
several options: Header Row, Total Row, Banded Rows, First Column, Last Column,
Banded Columns, and Filter Button.Select any cell in your table, then click the Design tab.

1. Check or uncheck the desired options in the Table Style Options group. In our
example, we'll check Total Row to automatically include a total for our table.

Page Layout Formulas Data Review View Design @ Tell me what you want to do...
ize with PivotTable D [:=] Properties Header Row | | First Column Filter Button
Duplicates 2 [ Open in Browser [ ] Total Row [ Last Colurmn
Insert  Export Refresh "
to Range Shicer > « B2 Unlink Banded Rows [ | Banded Columns

Tools External Table Data Table S5tyle Options
Total Row (Ctrl+Shift+T)

Turn on or off the total row of the
C table. E F

I Empanadas: Beef Picadillo

B [

2. The table style will be modified. In our example, a new row has been added to the
table with a formula that automatically calculates the total value of the cells in

column D.
A | B C D [
SABR [] SA Catering Invoice
. Sabrosa Empanadas & More voice #: SegEE
P 1202 Biscayne Bay Drive nvoice #:
S Orlando, FL 32804 Date: 05/10/16
1
JVENUITEM  EUNITPRICE EQUANTITY ELINETOTAL [
3 |[Empanadas: Beef Picadillo $2.99 15 544 .85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
s |Tamales: Chicken Tinga $2.29 20 $45.80
6 \Tamales: Vegetable $2.29 30 S$68.70
7 |Arepas: Carnitas $2.89 10 5$28.90
8 |Arepas: Queso Blanco $2.49 20 549.80
¢ Beverages: Horchata $1.89 25 547.25
10| Total - 5325.20‘
11

Depending on the type of content you have—and the table style you've chosen—these
options can affect your table's appearance in various ways. You may need to experiment with
a few different options to find the exact style you want.



10.3.4. To remove a table:

It's possible to remove a table from your workbook without losing any of your data.
However, this can cause issues with certain types of formatting, including colors, fonts, and
banded rows. Before you use this option, make sure you're prepared to reformat your cells if
necessary.

1. Select any cell in your table, then click the Design tab.
Click the Convert to Range command in the Tools group.

File Home Insert Page Layout Formulas Data Review View Design Q Tell me what yOou W
Table Mame: Summarize with PivotTable D Properties Header Row [ First Column
Table3 B-B Remove Duplicates 9> & Open in Browser Total Row [ Last Column

5 = Insert  Export Refresh
‘E] Resize Table &= Convert to Range HAiz > « €2 Unlink Banded Rows | | Banded Colu
Properties Tools External Table Data Table Style Optio
A10 Convert to Range
Convert this table into a normal
range of cells.
9 B 5 D [

3. A dialog box will appear. Click Yes.

A | B c D |

S ABR [] SA Catering Invoice
Sabrosa Empanadas & More

S 1202 Biscayne Bay Drive Invoice #: 56868

Orlando, FL 32804 Date: 05/10/16

Empanadas & More

AVENUTEM @ UNITPRICE EQUANTITY ELINETOTAL &
3 |[Empanadas: Beef B yicrosoft excel w L5 544,85
4 |Empanadas: Chipo 10 $39.90
5_ Tamales: ChiCken ‘I o Do you want to convert the table to a normal range? !D $4580
6 | Tamales: Vegetabl [ wes M C No | 30 $68.70
7 |Arepas: Carnitas S2.89 10 528.90
8 |Arepas: Queso Blanco $2.49 20 549.80
o Beverages: Horchata $1.89 25 S47.25
10| Total - 5325.2[]‘

4. The range will no longer be a table, but the cells will retain their data and formatting.

10



A A | B C D
S ABR [] SA Catering Invoice
: Sabrosa Empanadas & More i # SeaeE
D 1202 Biscayne Bay Drive nvoice #:
S Orlando, FL 32804 Date: 05/10/16
1
A MENU ITEM UNIT PRICE QUANTITY LINE TOTAL
3 |Empanadas: Beef Picadillo $2.99 15 S44.85
4 |Empanadas: Chipotle Shrimp $3.99 10 $39.90
5 |Tamales: Chicken Tinga $2.29 20 545.80
6 | Tamales: Vegetable $2.29 30 S68.70
7 |Arepas: Carnitas $2.89 10 528.90
s |Arepas: Queso Blanco $2.49 20 $49.80
g Beverages: Horchata $1.89 25 547.25
10| Total $325.20

To restart your formatting from scratch, click the Clear command on the Home tab. Next,

choose Clear Formats from the menu.

HE—*

B B [f]

Calculation

E AutoSum -

&y L

[ Fill - .
Mote . Insert Delete Format Sort & Find &
T @ - - L Clear~ Filter~ Select -
Cells & Clear All
Clear Formats

Z

Clear Contents

Clear Formats W X
=
Clear Comment Clear only the formatting that is

Clear Hyperlinks applied to the selected cells.
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